[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1447750924-9047-1-git-send-email-baiyaowei@cmss.chinamobile.com>
Date: Tue, 17 Nov 2015 17:02:04 +0800
From: Yaowei Bai <baiyaowei@...s.chinamobile.com>
To: akpm@...ux-foundation.org
Cc: bhe@...hat.com, dan.j.williams@...el.com,
dave.hansen@...ux.intel.com, dave@...olabs.net,
dhowells@...hat.com, dingel@...ux.vnet.ibm.com, hannes@...xchg.org,
hillf.zj@...baba-inc.com, holt@....com, iamjoonsoo.kim@....com,
joe@...ches.com, kuleshovmail@...il.com, mgorman@...e.de,
mhocko@...e.cz, mike.kravetz@...cle.com, n-horiguchi@...jp.nec.com,
penberg@...nel.org, rientjes@...gle.com, sasha.levin@...cle.com,
tj@...nel.org, tony.luck@...el.com, vbabka@...e.cz,
vdavydov@...allels.com, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: [PATCH] mm/zonelist: enumerate zonelists array index
Hardcoding index to zonelists array in gfp_zonelist() is not a good idea,
let's enumerate it to improve readability.
No functional change.
Signed-off-by: Yaowei Bai <baiyaowei@...s.chinamobile.com>
---
include/linux/gfp.h | 4 ++--
include/linux/mmzone.h | 20 +++++++++-----------
2 files changed, 11 insertions(+), 13 deletions(-)
diff --git a/include/linux/gfp.h b/include/linux/gfp.h
index 6523109..14a6249 100644
--- a/include/linux/gfp.h
+++ b/include/linux/gfp.h
@@ -378,9 +378,9 @@ static inline enum zone_type gfp_zone(gfp_t flags)
static inline int gfp_zonelist(gfp_t flags)
{
if (IS_ENABLED(CONFIG_NUMA) && unlikely(flags & __GFP_THISNODE))
- return 1;
+ return ZONELIST_NOFALLBACK;
- return 0;
+ return ZONELIST_FALLBACK;
}
/*
diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
index e23a9e7..bb31301 100644
--- a/include/linux/mmzone.h
+++ b/include/linux/mmzone.h
@@ -576,19 +576,17 @@ static inline bool zone_is_empty(struct zone *zone)
/* Maximum number of zones on a zonelist */
#define MAX_ZONES_PER_ZONELIST (MAX_NUMNODES * MAX_NR_ZONES)
+enum {
+ ZONELIST_FALLBACK, /* zonelist with fallback */
#ifdef CONFIG_NUMA
-
-/*
- * The NUMA zonelists are doubled because we need zonelists that restrict the
- * allocations to a single node for __GFP_THISNODE.
- *
- * [0] : Zonelist with fallback
- * [1] : No fallback (__GFP_THISNODE)
- */
-#define MAX_ZONELISTS 2
-#else
-#define MAX_ZONELISTS 1
+ /*
+ * The NUMA zonelists are doubled because we need zonelists that restrict
+ * the allocations to a single node for __GFP_THISNODE.
+ */
+ ZONELIST_NOFALLBACK, /* zonelist without fallback (__GFP_THISNODE) */
#endif
+ MAX_ZONELISTS
+};
/*
* This struct contains information about a zone in a zonelist. It is stored
--
1.9.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists