lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 23 Nov 2015 22:37:23 +0100
From:	Rasmus Villemoes <linux@...musvillemoes.dk>
To:	Albino B Neto <bino@...o.us>
Cc:	Alexander Viro <viro@...iv.linux.org.uk>,
	linux-fsdevel <linux-fsdevel@...r.kernel.org>,
	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] fs/file.c: __const_max is actually __const_min :-)

On Thu, Oct 29 2015, Albino B Neto <bino@...o.us> wrote:

> 2015-10-29 9:01 GMT-02:00 Rasmus Villemoes <linux@...musvillemoes.dk>:
>> 7f4b36f9bb930 "get rid of files_defer_init()" inexplicably changed a
>> min() to a __const_max() - but the __const_max macro actually gives
>> the minimum... So no functional change, just less confusing naming.
>>
>> Signed-off-by: Rasmus Villemoes <linux@...musvillemoes.dk>
>> ---
>>  fs/file.c | 6 +++---
>>  1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/fs/file.c b/fs/file.c
>> index 6c672ad329e9..b2d74f6001eb 100644
>> --- a/fs/file.c
>> +++ b/fs/file.c
>> @@ -25,9 +25,9 @@
>>
>>  int sysctl_nr_open __read_mostly = 1024*1024;
>>  int sysctl_nr_open_min = BITS_PER_LONG;
>> -/* our max() is unusable in constant expressions ;-/ */
>> -#define __const_max(x, y) ((x) < (y) ? (x) : (y))
>> -int sysctl_nr_open_max = __const_max(INT_MAX, ~(size_t)0/sizeof(void *)) &
>> +/* our min() is unusable in constant expressions ;-/ */
>> +#define __const_min(x, y) ((x) < (y) ? (x) : (y))
>> +int sysctl_nr_open_max = __const_min(INT_MAX, ~(size_t)0/sizeof(void *)) &
>>                          -BITS_PER_LONG;
>>
>>  static void *alloc_fdmem(size_t size)
>
> Confused code or no ?

The code is fine, the macro name sucks. Al, ping?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ