lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 8 Mar 2016 21:02:59 +0530
From:	Laxman Dewangan <ldewangan@...dia.com>
To:	Thierry Reding <treding@...dia.com>
CC:	<linus.walleij@...aro.org>, <robh+dt@...nel.org>,
	<pawel.moll@....com>, <mark.rutland@....com>,
	<devicetree@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
	<linux-gpio@...r.kernel.org>, <swarren@...dotorg.org>
Subject: Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed


On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>
>> Signed-off-by: Laxman Dewangan <ldewangan@...dia.com>
>> ---
>>   drivers/gpio/gpiolib.c | 9 +++++----
>>   1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>> index bc788b9..7575ebb 100644
>> --- a/drivers/gpio/gpiolib.c
>> +++ b/drivers/gpio/gpiolib.c
>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>>   
>>   	local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>>   	if (IS_ERR(local_desc)) {
>> -		pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
>> -		       name, chip->label, hwnum);
>> +		status = PTR_ERR(local_desc);
>> +		pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
>> +		       name, chip->label, hwnum, status);
> I find this type of format hard to read. I prefer a semi-colon to
> separate the message from the failure reason (i.e. error code).
>
> Besides that I don't understand why you're dropping the parentheses
> around the "chip %s, offset %d", I found that easier on the eye.
>
>


I did to accommodate the  3 extra character ( %d) for string format on 
that line as it was already near to 80 column.
Just did not want to split in multiple lines.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ