lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 14 May 2016 22:00:36 +0200
From:	Christian König <christian.koenig@....com>
To:	Muhammad Falak R Wani <falakreyaz@...il.com>,
	David Airlie <airlied@...ux.ie>
CC:	Nils Wallménius <nils.wallmenius@...il.com>,
	Jammy Zhou <Jammy.Zhou@....com>,
	<linux-kernel@...r.kernel.org>, <dri-devel@...ts.freedesktop.org>,
	Alex Deucher <alexander.deucher@....com>,
	Rex Zhu <Rex.Zhu@....com>,
	Christian König <christian.koenig@....com>,
	Dan Carpenter <dan.carpenter@...cle.com>
Subject: Re: [PATCH v2] drm/amd/powerplay: use ARRAY_SIZE() to calculate array
 size.

Am 13.05.2016 um 19:36 schrieb Muhammad Falak R Wani:
> It is preferred to use ARRAY_SIZE() for size calculation, instead
> using sizeof(array)/sizeof(*array). It makes the code more readable.
>
> Signed-off-by: Muhammad Falak R Wani <falakreyaz@...il.com>

Reviewed-by: Christian König <christian.koenig@....com>

Thanks for the cleanup,
Christian.

> ---
>   drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c b/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c
> index da18f44..87c023e 100644
> --- a/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c
> +++ b/drivers/gpu/drm/amd/powerplay/smumgr/cz_smumgr.c
> @@ -639,7 +639,7 @@ static int cz_smu_populate_firmware_entries(struct pp_smumgr *smumgr)
>   
>   	cz_smu->driver_buffer_length = 0;
>   
> -	for (i = 0; i < sizeof(firmware_list)/sizeof(*firmware_list); i++) {
> +	for (i = 0; i < ARRAY_SIZE(firmware_list); i++) {
>   
>   		firmware_type = cz_translate_firmware_enum_to_arg(smumgr,
>   					firmware_list[i]);

Powered by blists - more mailing lists