[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20160802103751.17826-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 18:37:51 +0800
From: Baole Ni <baolex.ni@...el.com>
To: b.zolnierkie@...sung.com, tj@...nel.org, lenb@...nel.org,
x86@...nel.org, hpa@...or.com
Cc: linux-ide@...r.kernel.org, linux-kernel@...r.kernel.org,
chuansheng.liu@...el.com, baolex.ni@...el.com, travis@....com
Subject: [PATCH 0061/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/ata/pata_ali.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/ata/pata_ali.c b/drivers/ata/pata_ali.c
index d19cd88..e104c6b 100644
--- a/drivers/ata/pata_ali.c
+++ b/drivers/ata/pata_ali.c
@@ -38,7 +38,7 @@
#define DRV_VERSION "0.7.8"
static int ali_atapi_dma = 0;
-module_param_named(atapi_dma, ali_atapi_dma, int, 0644);
+module_param_named(atapi_dma, ali_atapi_dma, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(atapi_dma, "Enable ATAPI DMA (0=disable, 1=enable)");
static struct pci_dev *ali_isa_bridge;
--
2.9.2
Powered by blists - more mailing lists