lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 2 Aug 2016 15:25:09 +0200
From:	Radim Krčmář <rkrcmar@...hat.com>
To:	Baole Ni <baolex.ni@...el.com>
Cc:	pbonzini@...hat.com, tglx@...utronix.de, mingo@...hat.com,
	hpa@...or.com, x86@...nel.org, kvm@...r.kernel.org,
	linux-kernel@...r.kernel.org, chuansheng.liu@...el.com
Subject: Re: [PATCH 0034/1285] Replace numeric parameter like 0444 with macro

2016-08-02 18:36+0800, Baole Ni:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
> 
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
> @@ -65,7 +65,7 @@ enum {
> -module_param(dbg, bool, 0644);
> +module_param(dbg, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);

Please change to "S_IWUSR | S_IRUGO".
0444 -> S_IRUGO should also be applied to other kvm patches.

The result is still less readable than 0644 for me, because octal
numbers are practically never used outside of well known access
permissions and those macros have to be read painfully carefully, but
macros avoid an arbitrary cutoff from flags that might not be known by
heart by all developers, maybe starting at S_ISVTX.


Btw. the posting could be improved with a cover letter that would link
all patches to it; the series will be easier to handle in mail clients
and there will be a clear place for common discussion about the
patchset.  Optionally merge related patches; one patch per subsystem
would be ideal.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ