[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20160802092642.47243e33@gandalf.local.home>
Date: Tue, 2 Aug 2016 09:26:42 -0400
From: Steven Rostedt <rostedt@...dmis.org>
To: Baole Ni <baolex.ni@...el.com>
Cc: jbaron@...mai.com, jiangshanlai@...il.com,
mathieu.desnoyers@...icios.com, m.chehab@...sung.com,
gregkh@...uxfoundation.org, m.szyprowski@...sung.com,
kyungmin.park@...sung.com, k.kozlowski@...sung.com,
linux-kernel@...r.kernel.org, chuansheng.liu@...el.com,
mhocko@...e.com, tglx@...utronix.de, vkuznets@...hat.com,
pmladek@...e.com, tj@...nel.org, jpoimboe@...hat.com
Subject: Re: [PATCH 1080/1285] Replace numeric parameter like 0444 with
macro
On Tue, 2 Aug 2016 20:14:36 +0800
Baole Ni <baolex.ni@...el.com> wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
NACK!
I find 0444 more readable than S_IRUSR | S_IRGRP | S_IROTH.
-- Steve
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> lib/dynamic_debug.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> index fe42b6e..853158e 100644
> --- a/lib/dynamic_debug.c
> +++ b/lib/dynamic_debug.c
> @@ -63,7 +63,7 @@ struct ddebug_iter {
> static DEFINE_MUTEX(ddebug_lock);
> static LIST_HEAD(ddebug_tables);
> static int verbose;
> -module_param(verbose, int, 0644);
> +module_param(verbose, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>
> /* Return the path relative to source root */
> static inline const char *trim_prefix(const char *path)
Powered by blists - more mailing lists