[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20160802105854.2073-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 18:58:54 +0800
From: Baole Ni <baolex.ni@...el.com>
To: rpurdie@...ys.net, j.anaszewski@...sung.com,
hal.rosenstock@...il.com, dledford@...hat.com,
sean.hefty@...el.com, bp@...en8.de
Cc: lguest@...ts.ozlabs.org, linux-kernel@...r.kernel.org,
rusty@...tcorp.com.au, mingo@...nel.org, chuansheng.liu@...el.com,
baolex.ni@...el.com
Subject: [PATCH 0309/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/lguest/interrupts_and_traps.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/lguest/interrupts_and_traps.c b/drivers/lguest/interrupts_and_traps.c
index 67392b6..ebd3723 100644
--- a/drivers/lguest/interrupts_and_traps.c
+++ b/drivers/lguest/interrupts_and_traps.c
@@ -21,7 +21,7 @@
/* Allow Guests to use a non-128 (ie. non-Linux) syscall trap. */
static unsigned int syscall_vector = IA32_SYSCALL_VECTOR;
-module_param(syscall_vector, uint, 0444);
+module_param(syscall_vector, uint, S_IRUSR | S_IRGRP | S_IROTH);
/* The address of the interrupt handler is split into two bits: */
static unsigned long idt_address(u32 lo, u32 hi)
--
2.9.2
Powered by blists - more mailing lists