[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <87h9b2y3vk.fsf@rustcorp.com.au>
Date: Wed, 03 Aug 2016 12:07:19 +0930
From: Rusty Russell <rusty@...tcorp.com.au>
To: Baole Ni <baolex.ni@...el.com>, rpurdie@...ys.net,
j.anaszewski@...sung.com, hal.rosenstock@...il.com,
dledford@...hat.com, sean.hefty@...el.com, bp@...en8.de
Cc: lguest@...ts.ozlabs.org, linux-kernel@...r.kernel.org,
mingo@...nel.org, chuansheng.liu@...el.com, baolex.ni@...el.com
Subject: Re: [PATCH 0309/1285] Replace numeric parameter like 0444 with macro
Baole Ni <baolex.ni@...el.com> writes:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
I find the numbers far, far more readable.
Cheers,
Rusty.
> /* Allow Guests to use a non-128 (ie. non-Linux) syscall trap. */
> static unsigned int syscall_vector = IA32_SYSCALL_VECTOR;
> -module_param(syscall_vector, uint, 0444);
> +module_param(syscall_vector, uint, S_IRUSR | S_IRGRP | S_IROTH);
>
> /* The address of the interrupt handler is split into two bits: */
> static unsigned long idt_address(u32 lo, u32 hi)
> --
> 2.9.2
Powered by blists - more mailing lists