[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.20.1609142049340.30349@nanos>
Date: Wed, 14 Sep 2016 20:52:22 +0200 (CEST)
From: Thomas Gleixner <tglx@...utronix.de>
To: Deepa Dinamani <deepa.kernel@...il.com>
cc: linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
arnd@...db.de, torvalds@...ux-foundation.org,
gregkh@...uxfoundation.org, akpm@...ux-foundation.org,
tytso@....edu, viro@...iv.linux.org.uk, y2038@...ts.linaro.org
Subject: Re: [PATCH v5 1/5] vfs: Add current_time() api
On Wed, 14 Sep 2016, Deepa Dinamani wrote:
> +/**
> + * current_time - Return FS time
> + * @inode: inode.
> + *
> + * Return the current time truncated to the time granularity supported by
> + * the fs.
> + *
> + * Note that inode and inode->sb cannot be NULL.
> + * Otherwise, the function warns and returns time without truncation.
> + */
> +struct timespec current_time(struct inode *inode)
Just a nitpick. Can we please rename that to fs_current_time() or something
similar which tells right away that this is a FS specific
function. current_time() is pretty generic and used in many places as
variable/argument name.
Thanks,
tglx
Powered by blists - more mailing lists