[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CABeXuvryJOB-7qr6PG7CC33yW+xh4ADv8=HwXQMZg1eT3ceE4A@mail.gmail.com>
Date: Wed, 14 Sep 2016 13:29:42 -0700
From: Deepa Dinamani <deepa.kernel@...il.com>
To: Thomas Gleixner <tglx@...utronix.de>
Cc: Linux FS-devel Mailing List <linux-fsdevel@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Arnd Bergmann <arnd@...db.de>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Greg KH <gregkh@...uxfoundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
"Theodore Ts'o" <tytso@....edu>,
Alexander Viro <viro@...iv.linux.org.uk>,
y2038 Mailman List <y2038@...ts.linaro.org>
Subject: Re: [PATCH v5 1/5] vfs: Add current_time() api
>> + * current_time - Return FS time
>> + * @inode: inode.
>> + *
>> + * Return the current time truncated to the time granularity supported by
>> + * the fs.
>> + *
>> + * Note that inode and inode->sb cannot be NULL.
>> + * Otherwise, the function warns and returns time without truncation.
>> + */
>> +struct timespec current_time(struct inode *inode)
>
> Just a nitpick. Can we please rename that to fs_current_time() or something
> similar which tells right away that this is a FS specific
> function. current_time() is pretty generic and used in many places as
> variable/argument name.
I proposed this as one of the names before:
https://lkml.org/lkml/2016/6/14/613 .
But, decided against it because of the inode argument.
If this is preferred, I will change the patches.
There are only about 30 (20, outside of staging) current_time
references outside of Documentation/
-Deepa
Powered by blists - more mailing lists