lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 7 Feb 2017 20:36:52 +0100
From:   SF Markus Elfring <elfring@...rs.sourceforge.net>
To:     linux-input@...r.kernel.org,
        Benjamin Tissoires <benjamin.tissoires@...hat.com>,
        Bruno Prémont <bonbons@...ux-vserver.org>,
        Jiri Kosina <jikos@...nel.org>
Cc:     LKML <linux-kernel@...r.kernel.org>,
        kernel-janitors@...r.kernel.org
Subject: [PATCH 00/18] HID: Fine-tuning for several function implementations

From: Markus Elfring <elfring@...rs.sourceforge.net>
Date: Tue, 7 Feb 2017 20:26:54 +0100

Several update suggestions were taken into account
from static source code analysis.

Markus Elfring (18):
  Use kmalloc_array() in hid_input_field()
  Delete an error message for a failed memory allocation in open_collection()
  Use kmalloc_array() in open_collection()
  Improve another size determination in open_collection()
  Improve two size determinations in hid_open_report()
  Improve another size determination in hid_scan_report()
  Improve another size determination in hid_register_report()
  Adjust five checks for null pointers
  Return an error code only as a constant in hid_allocate_device()
  debug: Replace five seq_printf() calls by seq_putc()
  debug: Delete an unnecessary seq_printf() call in hid_dump_device()
  debug: Replace 12 seq_printf() calls by seq_puts()
  debug: Combine 11 seq_printf() calls into one call in hid_dump_field()
  debug: Adjust two function calls together with a variable assignment
  debug: Return an error code only as a constant in hid_debug_events_open()
  debug: Add some spaces for better code readability
  debug: Delete an unnecessary variable initialisation in hid_resolv_usage()
  Use seq_puts() in picolcd_debug_reset_show()

 drivers/hid/hid-core.c            |  39 ++++++-------
 drivers/hid/hid-debug.c           | 115 +++++++++++++++++++-------------------
 drivers/hid/hid-picolcd_debugfs.c |   6 +-
 3 files changed, 78 insertions(+), 82 deletions(-)

-- 
2.11.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ