[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAMuHMdUGnXiOu5oDJ-DE+KGDZEB11P6cwnwdTPwd1HVBT4TqbA@mail.gmail.com>
Date: Wed, 8 Mar 2017 14:47:09 +0100
From: Geert Uytterhoeven <geert@...ux-m68k.org>
To: Magnus Damm <magnus.damm@...il.com>
Cc: Joerg Roedel <joro@...tes.org>,
Laurent Pinchart <laurent.pinchart+renesas@...asonboard.com>,
Geert Uytterhoeven <geert+renesas@...der.be>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Linux-Renesas <linux-renesas-soc@...r.kernel.org>,
iommu@...ts.linux-foundation.org,
Simon Horman <horms+renesas@...ge.net.au>,
Robin Murphy <robin.murphy@....com>,
Marek Szyprowski <m.szyprowski@...sung.com>
Subject: Re: [PATCH v3 02/09] iommu/ipmmu-vmsa: Add optional root device feature
Hi Magnus,
On Wed, Mar 8, 2017 at 12:01 PM, Magnus Damm <magnus.damm@...il.com> wrote:
> From: Magnus Damm <damm+renesas@...nsource.se>
>
> Add root device handling to the IPMMU driver by allowing certain
> DT compat strings to enable has_cache_leaf_nodes that in turn will
> support both root devices with interrupts and leaf devices that
> face the actual IPMMU consumer devices.
>
> Signed-off-by: Magnus Damm <damm+renesas@...nsource.se>
> --- 0011/drivers/iommu/ipmmu-vmsa.c
> +++ work/drivers/iommu/ipmmu-vmsa.c 2017-03-08 17:56:51.770607110 +0900
> @@ -216,6 +219,44 @@ static void set_archdata(struct device *
> #define IMUASID_ASID0_SHIFT 0
>
> /* -----------------------------------------------------------------------------
> + * Root device handling
> + */
> +
> +static bool ipmmu_is_root(struct ipmmu_vmsa_device *mmu)
> +{
> + if (mmu->features->has_cache_leaf_nodes)
> + return mmu->is_leaf ? false : true;
Expressions using the ternary operator are sometimes hard to read.
In this case, you want negation, so why not use that?
return !mmu->is_leaf;
> + else
I'd drop the else.
> + return true; /* older IPMMU hardware treated as single root */
> +}
> +
> +static struct ipmmu_vmsa_device *__ipmmu_find_root(void)
> +{
> + struct ipmmu_vmsa_device *mmu;
> + bool found = false;
struct ipmmu_vmsa_device *root = NULL;
> +
> + spin_lock(&ipmmu_devices_lock);
> +
> + list_for_each_entry(mmu, &ipmmu_devices, list) {
> + if (ipmmu_is_root(mmu)) {
> + found = true;
root = mmu;
> + break;
> + }
> + }
> +
> + spin_unlock(&ipmmu_devices_lock);
> + return found ? mmu : NULL;
return root;
> +}
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Powered by blists - more mailing lists