[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20170313010028.GA29728@zzz>
Date: Sun, 12 Mar 2017 18:00:28 -0700
From: Eric Biggers <ebiggers3@...il.com>
To: David Howells <dhowells@...hat.com>
Cc: linux-fsdevel@...r.kernel.org, Al Viro <viro@...iv.linux.org.uk>,
linux-kernel@...r.kernel.org, Eric Biggers <ebiggers@...gle.com>
Subject: Re: [PATCH v3] statx: optimize copy of struct statx to userspace
Hi David,
On Sun, Mar 12, 2017 at 09:11:53AM +0000, David Howells wrote:
> Eric Biggers <ebiggers3@...il.com> wrote:
>
> > +static int cp_statx(const struct kstat *stat, struct statx __user *buffer)
> > ...
> > + struct statx tmp;
>
> This function needs to be "noinline" as tmp is big.
>
> > - return statx_set_result(&stat, buffer);
> > +
> > + return cp_statx(&stat, buffer);
>
> Can you leave it as statx_set_result rather than renaming it to cp_statx?
>
> David
I agree with using 'noinline'.
But I think the name "cp_statx()" is better because it's consistent with the
existing functions in the file:
cp_old_stat()
cp_new_stat()
cp_new_stat64()
- Eric
Powered by blists - more mailing lists