[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75Vc+pK5cMkO=1dHR-Xx8zhe4RR0Zv5KDvChZE6MUfVQwcQ@mail.gmail.com>
Date: Wed, 3 May 2017 20:44:07 +0300
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: Johan Hovold <johan@...nel.org>
Cc: Rob Herring <robh@...nel.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"linux-serial@...r.kernel.org" <linux-serial@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Andrey Smirnov <andrew.smirnov@...il.com>
Subject: Re: [PATCH] tty: serdev: fix serdev_device_write return value
On Tue, May 2, 2017 at 12:25 PM, Johan Hovold <johan@...nel.org> wrote:
> On Mon, May 01, 2017 at 07:17:14PM -0500, Rob Herring wrote:
>> - return ret < 0 ? ret : (count ? -ETIMEDOUT : 0);
>> + return ret < 0 ? ret : (count ? -ETIMEDOUT : wr_cnt);
>
> That's some nasty use of the ternary operator. Ditching it completely
> would be more readable.
>
> if (ret < 0)
> return ret;
>
> if (count)
> return -ETIMEDOUT;
>
> return wr_count;
While I agree on the first part, I would go still with one ternary at the end:
return count ? -ETIMEDOUT : wr_count;
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists