lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170615142430.GA13398@gmail.com>
Date:   Thu, 15 Jun 2017 16:24:30 +0200
From:   Dawid Kurek <dawikur@...il.com>
To:     Jani Nikula <jani.nikula@...ux.intel.com>
Cc:     Daniel Vetter <daniel.vetter@...el.com>,
        Sean Paul <seanpaul@...omium.org>,
        David Airlie <airlied@...ux.ie>,
        dri-devel@...ts.freedesktop.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] drm: Reduce scope of 'state' variable

On 15/06/17, Jani Nikula wrote:
> On Thu, 15 Jun 2017, Dawid Kurek <dawikur@...il.com> wrote:
> > Smaller scope reduces visibility of variable and makes usage of
> > uninitialized variable less possible.
> > ---
> >  drivers/gpu/drm/drm_atomic.c | 5 +++--
> >  1 file changed, 3 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
> > index f32506a..ea5a9a7 100644
> > --- a/drivers/gpu/drm/drm_atomic.c
> > +++ b/drivers/gpu/drm/drm_atomic.c
> > @@ -108,10 +108,11 @@ struct drm_atomic_state *
> >  drm_atomic_state_alloc(struct drm_device *dev)
> >  {
> >  	struct drm_mode_config *config = &dev->mode_config;
> > -	struct drm_atomic_state *state;
> >  
> >  	if (!config->funcs->atomic_state_alloc) {
> > -		state = kzalloc(sizeof(*state), GFP_KERNEL);
> > +		struct drm_atomic_state *state
> > +			= kzalloc(sizeof(*state), GFP_KERNEL);
> 
> Separate declaration and initialization would lead to a cleaner patch
> and result.

I saw combining declaration and initialization is quite common, i.e. in
drm_atomic file. Personally, I also prefer those in one statement. But yes, it
looks cleaner here, in two lines.

v2 sent :)

Thanks,
Dawid

> 
> BR,
> Jani.
> 
> > +
> >  		if (!state)
> >  			return NULL;
> >  		if (drm_atomic_state_init(dev, state) < 0) {
> 
> -- 
> Jani Nikula, Intel Open Source Technology Center

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ