[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.20.1707021954270.2296@nanos>
Date: Sun, 2 Jul 2017 19:54:51 +0200 (CEST)
From: Thomas Gleixner <tglx@...utronix.de>
To: Dou Liyang <douly.fnst@...fujitsu.com>
cc: x86@...nel.org, linux-kernel@...r.kernel.org,
xen-devel@...ts.xenproject.org, mingo@...nel.org, hpa@...or.com,
ebiederm@...ssion.com, bhe@...hat.com, boris.ostrovsky@...cle.com,
peterz@...radead.org, izumi.taku@...fujitsu.com
Subject: Re: [PATCH v5 04/12] x86/apic: Move logical APIC ID away from
apic_bsp_setup()
On Fri, 30 Jun 2017, Dou Liyang wrote:
> /*
> diff --git a/arch/x86/kernel/smpboot.c b/arch/x86/kernel/smpboot.c
> index 93f0cda..d6721f0 100644
> --- a/arch/x86/kernel/smpboot.c
> +++ b/arch/x86/kernel/smpboot.c
> @@ -1347,8 +1347,11 @@ void __init native_smp_prepare_cpus(unsigned int max_cpus)
> }
>
> default_setup_apic_routing();
> - cpu0_logical_apicid = apic_bsp_setup(false);
> -
> + apic_bsp_setup(false);
> + if (x2apic_mode)
> + cpu0_logical_apicid = apic_read(APIC_LDR);
> + else
> + cpu0_logical_apicid = GET_APIC_LOGICAL_ID(apic_read(APIC_LDR));
Can you please move that into a seperate helper function?
> /* Setup local timer */
> x86_init.timers.setup_percpu_clockev();
>
> --
> 2.5.5
>
>
>
>
Powered by blists - more mailing lists