[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAL_JsqK6ioLTv+hgb7kZS2ySnDuM_FuOCUGBhtCG8hT607Js_Q@mail.gmail.com>
Date: Wed, 26 Jul 2017 09:34:17 -0500
From: Rob Herring <robh@...nel.org>
To: David Laight <David.Laight@...lab.com>
Cc: "devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
"linuxppc-dev@...ts.ozlabs.org" <linuxppc-dev@...ts.ozlabs.org>,
Frank Rowand <frowand.list@...il.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Paul Mackerras <paulus@...ba.org>
Subject: Re: [PATCH 3/4] powerpc: pseries: only store the device node basename
in full_name
On Wed, Jul 26, 2017 at 5:07 AM, David Laight <David.Laight@...lab.com> wrote:
> From: Rob Herring
>> Sent: 25 July 2017 22:44
>> With dependencies on full_name containing the entire device node path
>> removed, stop storing the full_name in nodes created by
>> dlpar_configure_connector() and pSeries_reconfig_add_node().
> ...
>> dn = kzalloc(sizeof(*dn), GFP_KERNEL);
>> if (!dn)
>> return NULL;
>>
>> name = (char *)ccwa + be32_to_cpu(ccwa->name_offset);
>> - dn->full_name = kasprintf(GFP_KERNEL, "%s/%s", path, name);
>> + dn->full_name = kasprintf(GFP_KERNEL, "%s", name);
>
> Isn't this just strdup()?
Yes, it can be simplified to that now.
> Perhaps you should rename full_name to name - since it is no longer 'full'?
Ideally, yes. However, we still have users in other places tree wide
(which should still work with the change) and I don't think it is
worth the additional churn. Also, we already have "name" as that is
the node name without the unit-address. I'd like to get rid of that,
but name is special in that it is exposed as a property too. Finally,
full_name is still the full path on Sparc.
> Maybe you could do a single malloc() for both 'dn' and the name?
Sure.
Rob
Powered by blists - more mailing lists