[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170901104456.GA25892@infradead.org>
Date: Fri, 1 Sep 2017 03:44:56 -0700
From: Christoph Hellwig <hch@...radead.org>
To: Thomas Gleixner <tglx@...utronix.de>
Cc: Christoph Hellwig <hch@...radead.org>,
Kees Cook <keescook@...omium.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: Converting struct timer_list callback argument to struct
timer_list *
On Fri, Sep 01, 2017 at 12:21:46PM +0200, Thomas Gleixner wrote:
> On Fri, 1 Sep 2017, Christoph Hellwig wrote:
>
> > Good work!
> >
> > I just think that the TIMER_CONTAINER name is revolting.
> >
> > The usual name for such a helper fitting other uses like lists
> > and rbtrees would be timer_entry, and that also reads much better.
>
> I think the plan is to remove that thing afterward, because then the
> callback function is:
>
> void func(struct timer_list *timer)
>
> So I don't mind the ugly name as it should be simply removed once the tree
> is converted over.
Well, we can't just remove it, we could just replace it with
container_of(). lists and rbtrees just keep their list_entry and
rb_entry wrappers for timer_of, so we could save us the additional
churn by naming it timer_entry and just keeping it.
Powered by blists - more mailing lists