lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 8 Oct 2017 02:16:54 -0700
From:   Christoph Hellwig <>
To:     Konstantin Khlebnikov <>
Cc:, Andrew Morton <>,, Andy Lutomirski <>
Subject: Re: [PATCH] vmalloc: add __alloc_vm_area() for optimizing vmap stack

This looks fine in general, but a few comments:

 - can you split adding the new function from switching over the fork
 - at least kasan and vmalloc_user/vmalloc_32_user use very similar
   patterns, can you switch them over as well?
 - the new __alloc_vm_area looks very different from alloc_vm_area,
   maybe it needs a better name?  vmalloc_range_area for example?
 - when you split an existing function please keep the more low-level
   function on top of the higher level one that calls it.

Powered by blists - more mailing lists