lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 25 Oct 2017 08:03:13 +0200
From:   SF Markus Elfring <elfring@...rs.sourceforge.net>
To:     Günter Röck <linux@...ck-us.net>,
        linux-hwmon@...r.kernel.org
Cc:     Jean Delvare <jdelvare@...e.com>,
        LKML <linux-kernel@...r.kernel.org>,
        kernel-janitors@...r.kernel.org
Subject: Re: hwmon/amc6821: Use common error handling code in
 amc6821_init_client()

> Nack; I am not a friend of that much verboseness to start with,
> and I don't think the patch improves readability.

* Do you care to avoid code duplication for two error messages in this use case?

* How do you think about to return a single error code directly
  without using an intermediate variable?

Regards,
Markus

Powered by blists - more mailing lists