lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 25 Oct 2017 09:37:17 +0200
From:   Benjamin Tissoires <benjamin.tissoires@...hat.com>
To:     SF Markus Elfring <elfring@...rs.sourceforge.net>
Cc:     linux-input@...r.kernel.org, Jiri Kosina <jikos@...nel.org>,
        LKML <linux-kernel@...r.kernel.org>,
        kernel-janitors@...r.kernel.org
Subject: Re: [PATCH] HID: hidraw: Improve a size determination in two
 functions

On Oct 24 2017 or thereabouts, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@...rs.sourceforge.net>
> Date: Tue, 24 Oct 2017 20:52:19 +0200
> 
> * Replace the specification of data structures by pointer dereferences
>   as the parameter for the operator "sizeof" to make the corresponding size
>   determination a bit safer according to the Linux coding style convention.
> 
>   This issue was detected by using the Coccinelle software.
> 
> * Return directly after a call of the function "kzalloc" failed
>   at the beginning of the function "hidraw_open".
> 
> * Delete the jump target "out" which became unnecessary
>   with this refactoring.
> 
> Signed-off-by: Markus Elfring <elfring@...rs.sourceforge.net>
> ---
>  drivers/hid/hidraw.c | 10 ++++------
>  1 file changed, 4 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/hid/hidraw.c b/drivers/hid/hidraw.c
> index 5fbe0f81ab2e..26fbf9e82f84 100644
> --- a/drivers/hid/hidraw.c
> +++ b/drivers/hid/hidraw.c
> @@ -269,10 +269,9 @@ static int hidraw_open(struct inode *inode, struct file *file)
>  	unsigned long flags;
>  	int err = 0;
>  
> -	if (!(list = kzalloc(sizeof(struct hidraw_list), GFP_KERNEL))) {
> -		err = -ENOMEM;
> -		goto out;
> -	}
> +	list = kzalloc(sizeof(*list), GFP_KERNEL);

I am not sure the change from "if (!a = kzalloc())" to "a = kzalloc();
if (!a)" adds anything besides clearer code. I prefer the later, so:

Reviewed-by: Benjamin Tissoires <benjamin.tissoires@...hat.com>

Cheers,
Benjamin

> +	if (!list)
> +		return -ENOMEM;
>  
>  	mutex_lock(&minors_lock);
>  	if (!hidraw_table[minor] || !hidraw_table[minor]->exist) {
> @@ -304,7 +303,6 @@ static int hidraw_open(struct inode *inode, struct file *file)
>  	file->private_data = list;
>  out_unlock:
>  	mutex_unlock(&minors_lock);
> -out:
>  	if (err < 0)
>  		kfree(list);
>  	return err;
> @@ -513,7 +511,7 @@ int hidraw_connect(struct hid_device *hid)
>  
>  	/* we accept any HID device, all applications */
>  
> -	dev = kzalloc(sizeof(struct hidraw), GFP_KERNEL);
> +	dev = kzalloc(sizeof(*dev), GFP_KERNEL);
>  	if (!dev)
>  		return -ENOMEM;
>  
> -- 
> 2.14.3
> 

Powered by blists - more mailing lists