lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 2 Nov 2017 10:21:55 +0530
From:   Viresh Kumar <viresh.kumar@...aro.org>
To:     Stephen Boyd <sboyd@...eaurora.org>
Cc:     Rob Herring <robh+dt@...nel.org>,
        Ulf Hansson <ulf.hansson@...aro.org>,
        Kevin Hilman <khilman@...nel.org>,
        Viresh Kumar <vireshk@...nel.org>, Nishanth Menon <nm@...com>,
        Rafael Wysocki <rjw@...ysocki.net>,
        "linux-pm@...r.kernel.org" <linux-pm@...r.kernel.org>,
        Vincent Guittot <vincent.guittot@...aro.org>,
        Rajendra Nayak <rnayak@...eaurora.org>,
        Sudeep Holla <sudeep.holla@....com>,
        "devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [RFC V7 2/2] OPP: Allow "opp-hz" and "opp-microvolt" to contain
 magic values

On 01-11-17, 14:43, Stephen Boyd wrote:
> On 11/01, Rob Herring wrote:
> > On Tue, Oct 31, 2017 at 9:17 PM, Viresh Kumar <viresh.kumar@...aro.org> wrote:
> > > On 31 October 2017 at 16:02, Rob Herring <robh+dt@...nel.org> wrote:
> > >> Why not a new property for magic values? opp-magic? Don't we want to
> > >> know when we have magic values?
> > >
> > > I have kept a separate property since beginning (domain-performance-state)
> > > and moved to using these magic values in the existing field because of the
> > > suggestion Kevin gave earlier.
> > >
> > > https://marc.info/?l=linux-kernel&m=149306082218001&w=2
> > >
> > > I am not sure what to do now :)
> > 
> > Okay, I guess reusing the properties is fine.
> > 
> 
> We call them corners on qcom platforms. Any reason we can't keep
> using that name? I'd rather not have to keep telling people that
> these fake values in some misnamed property is actually a corner.

Surely not "corners", as these are platform and OS independent
bindings we are talking about here. Even the kernel code shouldn't
generally do that. Though your platform specific genpd driver can :)

-- 
viresh

Powered by blists - more mailing lists