[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAPcyv4iB73a1FNSzUdes94SxoELJmEteDeewjxW86D0akeOjaA@mail.gmail.com>
Date: Wed, 15 Nov 2017 07:17:39 -0800
From: Dan Williams <dan.j.williams@...el.com>
To: Haozhong Zhang <haozhong.zhang@...el.com>
Cc: KVM list <kvm@...r.kernel.org>, X86 ML <x86@...nel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Paolo Bonzini <pbonzini@...hat.com>, rkrcmar@...hat.com,
Xiao Guangrong <xiaoguangrong.eric@...il.com>,
"Cuevas Escareno, Ivan D" <ivan.d.cuevas.escareno@...el.com>,
"Kumar, Karthik" <karthik.kumar@...el.com>,
Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>,
Olif Chapman <olif.chapman@...cle.com>,
Mikulas Patocka <mpatocka@...hat.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>, Borislav Petkov <bp@...e.de>,
Tom Lendacky <thomas.lendacky@....com>
Subject: Re: [PATCH v5 1/2] x86/mm: add a function to check if a pfn is UC/UC-
On Tue, Nov 7, 2017 at 11:56 PM, Haozhong Zhang
<haozhong.zhang@...el.com> wrote:
> It will be used by KVM to check whether a pfn should be
> mapped to guest as UC.
>
> Signed-off-by: Haozhong Zhang <haozhong.zhang@...el.com>
> ---
> arch/x86/include/asm/pat.h | 2 ++
> arch/x86/mm/pat.c | 16 ++++++++++++++++
> 2 files changed, 18 insertions(+)
>
> diff --git a/arch/x86/include/asm/pat.h b/arch/x86/include/asm/pat.h
> index fffb2794dd89..fabb0cf00e77 100644
> --- a/arch/x86/include/asm/pat.h
> +++ b/arch/x86/include/asm/pat.h
> @@ -21,4 +21,6 @@ int io_reserve_memtype(resource_size_t start, resource_size_t end,
>
> void io_free_memtype(resource_size_t start, resource_size_t end);
>
> +bool pat_pfn_is_uc_or_uc_minus(unsigned long pfn);
> +
> #endif /* _ASM_X86_PAT_H */
> diff --git a/arch/x86/mm/pat.c b/arch/x86/mm/pat.c
> index fe7d57a8fb60..e1282dd4eeb8 100644
> --- a/arch/x86/mm/pat.c
> +++ b/arch/x86/mm/pat.c
> @@ -677,6 +677,22 @@ static enum page_cache_mode lookup_memtype(u64 paddr)
> return rettype;
> }
>
> +/**
> + * Check with PAT whether the memory type of a pfn is UC or UC-.
> + *
> + * Only to be called when PAT is enabled.
> + *
> + * Returns true, if the memory type of @pfn is UC or UC-.
> + * Otherwise, returns false.
> + */
> +bool pat_pfn_is_uc_or_uc_minus(unsigned long pfn)
> +{
> + enum page_cache_mode cm = lookup_memtype(PFN_PHYS(pfn));
> +
> + return cm == _PAGE_CACHE_MODE_UC || cm == _PAGE_CACHE_MODE_UC_MINUS;
> +}
> +EXPORT_SYMBOL_GPL(pat_pfn_is_uc_or_uc_minus);
Why do we need this strangely named new accessor? It seems to be
open-coding a new / more limited version of track_pfn_insert().
Powered by blists - more mailing lists