lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 21 Nov 2017 12:47:00 -0700
From:   Shuah Khan <shuah@...nel.org>
To:     SF Markus Elfring <elfring@...rs.sourceforge.net>,
        linux-pm@...r.kernel.org, Thomas Renninger <trenn@...e.com>
Cc:     LKML <linux-kernel@...r.kernel.org>,
        kernel-janitors@...r.kernel.org,
        Shuah Khan <shuahkh@....samsung.com>,
        Shuah Khan <shuah@...nel.org>
Subject: Re: [PATCH] cpupower: Combine two condition checks into one statement
 in get_cpu_topology()

On 11/20/2017 11:19 AM, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@...rs.sourceforge.net>
> Date: Mon, 20 Nov 2017 19:10:14 +0100
> 
> The same assignments were used in an if branch of two separate statements.
> 
> * Merge their condition checks into a single statement instead.
> 
> * Adjust the indentation there.
> 
> This issue was detected by using the Coccinelle software.
> 
> Signed-off-by: Markus Elfring <elfring@...rs.sourceforge.net>
> ---
>  tools/power/cpupower/lib/cpupower.c | 18 ++++++------------
>  1 file changed, 6 insertions(+), 12 deletions(-)
> 
> diff --git a/tools/power/cpupower/lib/cpupower.c b/tools/power/cpupower/lib/cpupower.c
> index 9c395ec924de..81c828e5920e 100644
> --- a/tools/power/cpupower/lib/cpupower.c
> +++ b/tools/power/cpupower/lib/cpupower.c
> @@ -140,18 +140,12 @@ int get_cpu_topology(struct cpupower_topology *cpu_top)
>  	for (cpu = 0; cpu < cpus; cpu++) {
>  		cpu_top->core_info[cpu].cpu = cpu;
>  		cpu_top->core_info[cpu].is_online = cpupower_is_cpu_online(cpu);
> -		if(sysfs_topology_read_file(
> -			cpu,
> -			"physical_package_id",
> -			&(cpu_top->core_info[cpu].pkg)) < 0) {
> -			cpu_top->core_info[cpu].pkg = -1;
> -			cpu_top->core_info[cpu].core = -1;
> -			continue;
> -		}
> -		if(sysfs_topology_read_file(
> -			cpu,
> -			"core_id",
> -			&(cpu_top->core_info[cpu].core)) < 0) {
> +		if (sysfs_topology_read_file(cpu, "physical_package_id",
> +					     &(cpu_top->core_info[cpu].pkg))
> +		    < 0 ||
> +		    sysfs_topology_read_file(cpu, "core_id",
> +					     &(cpu_top->core_info[cpu].core))
> +		    < 0) {

This change takes the easily readable code into hard to read code,
even though it removes the duplicate code in the conditional.

Please find a better way to make it not so hard to read.

thanks,
-- Shuah

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ