[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d1246ed7-49d2-54a5-ba50-9451d475940b@gmail.com>
Date: Tue, 28 Nov 2017 20:39:31 +0100
From: Heiner Kallweit <hkallweit1@...il.com>
To: Bartosz Golaszewski <brgl@...ev.pl>
Cc: Andy Shevchenko <andy.shevchenko@...il.com>,
Claudiu Beznea <Claudiu.Beznea@...rochip.com>,
linux-i2c <linux-i2c@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
stable@...r.kernel.org
Subject: Re: [PATCH] eeprom: at24: correctly set the size for at24mac402
Am 28.11.2017 um 13:09 schrieb Andy Shevchenko:
> On Mon, Nov 27, 2017 at 11:06 PM, Bartosz Golaszewski <brgl@...ev.pl> wrote:
>> There's an ilog2() expansion in AT24_DEVICE_MAGIC() which rounds down
>> the actual size of EUI-48 byte array in at24mac402 eeproms to 4 from 6,
>> making it impossible to read it all.
>>
>> Fix it by manually adjusting the value in probe().
>>
>> This patch contains a temporary fix that is suitable for stable
>> branches. Eventually we'll probably remove the call to ilog2() while
>> converting the magic values to actual structs.
>>
>
> Reviewed-by: Andy Shevchenko <andy.shevchenko@...il.com>
>
Looks good also to me.
>> Cc: stable@...r.kernel.org
>> Fixes: 0b813658c115 ("eeprom: at24: add support for at24mac series")
>> Signed-off-by: Bartosz Golaszewski <brgl@...ev.pl>
>> ---
>> drivers/misc/eeprom/at24.c | 10 ++++++++++
>> 1 file changed, 10 insertions(+)
>>
>> diff --git a/drivers/misc/eeprom/at24.c b/drivers/misc/eeprom/at24.c
>> index e0b4b36ef010..783244b485cc 100644
>> --- a/drivers/misc/eeprom/at24.c
>> +++ b/drivers/misc/eeprom/at24.c
>> @@ -730,6 +730,16 @@ static int at24_probe(struct i2c_client *client, const struct i2c_device_id *id)
>> dev_warn(&client->dev,
>> "page_size looks suspicious (no power of 2)!\n");
>>
>> + /*
>> + * REVISIT: the size of the EUI-48 byte array is 6 in at24mac402, while
>> + * the call to ilog2() in AT24_DEVICE_MAGIC() rounds it down to 4.
>> + *
>> + * Eventually we'll get rid of the magic values altoghether in favor of
>> + * real structs, but for now just manually set the right size.
>> + */
>> + if (chip.flags & AT24_FLAG_MAC && chip.byte_len == 4)
>> + chip.byte_len = 6;
>> +
>> /* Use I2C operations unless we're stuck with SMBus extensions. */
>> if (!i2c_check_functionality(client->adapter, I2C_FUNC_I2C)) {
>> if (chip.flags & AT24_FLAG_ADDR16)
>> --
>> 2.15.0
>>
>
>
>
Powered by blists - more mailing lists