[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <cefc820d-5626-73ef-9b99-8c1d191e5ae7@microchip.com>
Date: Mon, 4 Dec 2017 14:36:43 +0200
From: Claudiu Beznea <Claudiu.Beznea@...rochip.com>
To: Bartosz Golaszewski <brgl@...ev.pl>,
Andy Shevchenko <andy.shevchenko@...il.com>
CC: Heiner Kallweit <hkallweit1@...il.com>,
linux-i2c <linux-i2c@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
<stable@...r.kernel.org>
Subject: Re: [PATCH] eeprom: at24: correctly set the size for at24mac402
On 28.11.2017 12:44, Bartosz Golaszewski wrote:
> 2017-11-28 11:25 GMT+01:00 Andy Shevchenko <andy.shevchenko@...il.com>:
>> On Mon, Nov 27, 2017 at 11:06 PM, Bartosz Golaszewski <brgl@...ev.pl> wrote:
>>> There's an ilog2() expansion in AT24_DEVICE_MAGIC() which rounds down
>>> the actual size of EUI-48 byte array in at24mac402 eeproms to 4 from 6,
>>> making it impossible to read it all.
>>>
>>> Fix it by manually adjusting the value in probe().
>>>
>>> This patch contains a temporary fix that is suitable for stable
>>> branches. Eventually we'll probably remove the call to ilog2() while
>>> converting the magic values to actual structs.
>>
>>> + /*
>>> + * REVISIT: the size of the EUI-48 byte array is 6 in at24mac402, while
>>> + * the call to ilog2() in AT24_DEVICE_MAGIC() rounds it down to 4.
>>> + *
>>> + * Eventually we'll get rid of the magic values altoghether in favor of
>>> + * real structs, but for now just manually set the right size.
>>> + */
>>> + if (chip.flags & AT24_FLAG_MAC && chip.byte_len == 4)
>>
>> I didn't check, but do we need to test for len == 4 at all?
>>
>>> + chip.byte_len = 6;
>>
>> --
>> With Best Regards,
>> Andy Shevchenko
>
> Yes, because the fix is only relevant for at24mac402 whose MAC byte
> array is 6 bytes long, while the one in at24mac602 is 8 bytes and the
> driver doesn't truncate the byte_len for it.
>From my point of view, I think all chips in at24_ids[] array should be checked
about restrictions regarding the size truncation (especially the ones from the
initial commit: "2b7a5056a0a7ff17d5d2 i2c: New-style EEPROM driver using device IDs"
which introduces AT24_DEVICE_MAGIC() macro) and if none of them has such restrictions
we should get rid of the ilog2() restrictions.
Just my 2 cents...
Claudiu
>
> Thanks,
> Bartosz
>
Powered by blists - more mailing lists