lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 6 Dec 2017 12:36:33 +0200
From:   Marcus Wolf <>
To:     Dan Carpenter <>
Cc:     Simon Sandström <>,,,,
Subject: Re: [PATCH v2 06/11] staging: pi433: Split rf69_set_crc_enabled into
 two functions

 >> rf69 -set/get - action
 >> -> rf69_set_crc_enable
 > No...  Simon's name is better.  His is shorter and makes more sense.

I disagree. If I am going to implement a new functionality and need to 
think about the naming of the function name, every time I need to change 
a register setting that's awfull.

I usually have code on one monitor and datasheet on the other. So if I 
want to set a bit/reg/whatever, I have the datasheet in front of my 
nose. I can easy write the code, if function names refer to the names in 
the datasheet and follow a strict naming convention. If the naming 
convetion is broken, I need to switch to the header and search manually 
for each register, I want to set.

There is so much potential in this young driver, that could be 
developed. Would be pitty, if all that wouldn't take place some day.


Powered by blists - more mailing lists