lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 6 Dec 2017 15:52:28 +0100
From:   Greg KH <>
To:     Marcus Wolf <>
Subject: Re: [PATCH V3] staging: pi433: rf69.c: Replace macros READ_REG and
 WRITE_REG with smarter functions

On Mon, Dec 04, 2017 at 11:45:16PM +0200, Marcus Wolf wrote:
> To increase the readability of the register accesses, the abstraction
> of the helpers was increased from simple read and write to set bit,
> clear bit and read modify write bit.
> Annotation: This patch contains a lot of long lines and camel case
> var names. These long lines and camel case vars weren't introduced
> by this patch, but were long and camel cased before.
> Signed-off-by: Marcus Wolf <>
> ---
>  drivers/staging/pi433/rf69.c |  336 ++++++++++++++++++++++--------------------
>  1 file changed, 180 insertions(+), 156 deletions(-)

When doing a second or third or forth version of a patch, always include
below the --- line what changed from the previous versions.  The
in-kernel documentation for how to submit a patch should have all of the
needed information on this.

No need here, just for the future patches.


greg k-h

Powered by blists - more mailing lists