lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 9 Dec 2017 09:49:38 -0800
From:   Alexei Starovoitov <>
To:     David Ahern <>
Cc:     Eric Leblond <>,,,,
Subject: Re: [PATCH net-next] libbpf: add function to setup XDP

On Sat, Dec 09, 2017 at 09:34:46AM -0700, David Ahern wrote:
> On 12/9/17 7:43 AM, Eric Leblond wrote:
> > +	/* started nested attribute for XDP */
> > +	nla = (struct nlattr *)(((char *)&req)
> > +				+ NLMSG_ALIGN(req.nh.nlmsg_len));
> > +	nla->nla_type = NLA_F_NESTED | 43/*IFLA_XDP*/;
> as a part of the move into libbpf can the magic numbers be replaced by
> the names directly and there as a comment?

In general it would be nice to use names instead of numbers,
but it's much bigger change then this patch, since it would require
copying and syncing a bunch of headers into tools/ which may not be such
a good idea in the end.

Only removal of min() looks a bit suspicious to me.
Eric, is it because it now comes from some header?

Powered by blists - more mailing lists