[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1515388281-7941-1-git-send-email-gupta.namit@samsung.com>
Date: Mon, 8 Jan 2018 10:41:21 +0530
From: Namit Gupta <gupta.namit@...sung.com>
To: rostedt@...dmis.org, jeyu@...nel.org
Cc: mingo@...hat.com, linux-kernel@...r.kernel.org,
pankaj.m@...sung.com, a.sahrawat@...sung.com,
Namit Gupta <gupta.namit@...sung.com>
Subject: [PATCH v3] ftrace/module: Move ftrace_release_mod() to
ddebug_cleanup label
ftrace_module_init happen after dynamic_debug_setup, it is desired that
cleanup should be called after this label however in current implementation
it is called in free module label,ie:even though ftrace in not initialized,
from so many fail case ftrace_release_mod() will be called and unnecessary
traverse the whole list.
In below patch we moved ftrace_release_mod() from free_module label to
ddebug_cleanup label. that is the best possible location, other solution
is to make new label to ftrace_release_mod() but since ftrace_module_init()
is not return with minimum changes it should be in ddebug_cleanup label.
Signed-off-by: Namit Gupta <gupta.namit@...sung.com>
---
kernel/module.c | 7 +------
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/kernel/module.c b/kernel/module.c
index de66ec8..e81a6d7 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -3779,6 +3779,7 @@ static int load_module(struct load_info *info, const char __user *uargs,
module_disable_nx(mod);
ddebug_cleanup:
+ ftrace_release_mod(mod);
dynamic_debug_remove(mod, info->debug);
synchronize_sched();
kfree(mod->args);
@@ -3798,12 +3799,6 @@ static int load_module(struct load_info *info, const char __user *uargs,
synchronize_sched();
mutex_unlock(&module_mutex);
free_module:
- /*
- * Ftrace needs to clean up what it initialized.
- * This does nothing if ftrace_module_init() wasn't called,
- * but it must be called outside of module_mutex.
- */
- ftrace_release_mod(mod);
/* Free lock-classes; relies on the preceding sync_rcu() */
lockdep_free_key_range(mod->core_layout.base, mod->core_layout.size);
--
1.9.1
Powered by blists - more mailing lists