[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <9c21cf88-84bd-c951-59eb-c0a5b31dadb3@linux.vnet.ibm.com>
Date: Mon, 15 Jan 2018 18:42:11 +0100
From: Laurent Dufour <ldufour@...ux.vnet.ibm.com>
To: Matthew Wilcox <willy@...radead.org>
Cc: paulmck@...ux.vnet.ibm.com, peterz@...radead.org,
akpm@...ux-foundation.org, kirill@...temov.name,
ak@...ux.intel.com, mhocko@...nel.org, dave@...olabs.net,
jack@...e.cz, benh@...nel.crashing.org, mpe@...erman.id.au,
paulus@...ba.org, Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, hpa@...or.com,
Will Deacon <will.deacon@....com>,
Sergey Senozhatsky <sergey.senozhatsky@...il.com>,
Andrea Arcangeli <aarcange@...hat.com>,
Alexei Starovoitov <alexei.starovoitov@...il.com>,
kemi.wang@...el.com, sergey.senozhatsky.work@...il.com,
linux-kernel@...r.kernel.org, linux-mm@...ck.org,
haren@...ux.vnet.ibm.com, khandual@...ux.vnet.ibm.com,
npiggin@...il.com, bsingharora@...il.com,
Tim Chen <tim.c.chen@...ux.intel.com>,
linuxppc-dev@...ts.ozlabs.org, x86@...nel.org
Subject: Re: [PATCH v6 16/24] mm: Protect mm_rb tree with a rwlock
Hi Matthew,
Thanks for reviewing this series.
On 12/01/2018 19:48, Matthew Wilcox wrote:
> On Fri, Jan 12, 2018 at 06:26:00PM +0100, Laurent Dufour wrote:
>> -static void __vma_rb_erase(struct vm_area_struct *vma, struct rb_root *root)
>> +static void __vma_rb_erase(struct vm_area_struct *vma, struct mm_struct *mm)
>> {
>> + struct rb_root *root = &mm->mm_rb;
>> /*
>> * Note rb_erase_augmented is a fairly large inline function,
>> * so make sure we instantiate it only once with our desired
>> * augmented rbtree callbacks.
>> */
>> +#ifdef CONFIG_SPF
>> + write_lock(&mm->mm_rb_lock);
>> +#endif
>> rb_erase_augmented(&vma->vm_rb, root, &vma_gap_callbacks);
>> +#ifdef CONFIG_SPF
>> + write_unlock(&mm->mm_rb_lock); /* wmb */
>> +#endif
>
> I can't say I love this. Have you considered:
>
> #ifdef CONFIG_SPF
> #define vma_rb_write_lock(mm) write_lock(&mm->mm_rb_lock)
> #define vma_rb_write_unlock(mm) write_unlock(&mm->mm_rb_lock)
> #else
> #define vma_rb_write_lock(mm) do { } while (0)
> #define vma_rb_write_unlock(mm) do { } while (0)
> #endif
I haven't consider this, but this sounds to be smarter. I'll do that.
> Also, SPF is kind of uninformative. CONFIG_MM_SPF might be better?
> Or perhaps even CONFIG_SPECULATIVE_PAGE_FAULT, just to make it really
> painful to do these one-liner ifdefs that make the code so hard to read.
Thomas also complained about that, and I agree, SPF is quite cryptic. This
being said, I don't think that CONFIG_MM_SPF will be far better, so I'll
change this define to CONFIG_SPECULATIVE_PAGE_FAULT, even if it's longer,
it should not be too much present in the code.
Thanks,
Laurent.
Powered by blists - more mailing lists