[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180530183241.GA20222@wunner.de>
Date: Wed, 30 May 2018 20:32:41 +0200
From: Lukas Wunner <lukas@...ner.de>
To: Bjorn Helgaas <helgaas@...nel.org>
Cc: linux-pci@...r.kernel.org, Oza Pawandeep <poza@...eaurora.org>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v1 1/2] PCI/AER: Decode Error Source Requester ID
On Wed, May 30, 2018 at 12:54:15PM -0500, Bjorn Helgaas wrote:
> void aer_print_port_info(struct pci_dev *dev, struct aer_err_info *info)
> {
> - pci_info(dev, "AER: %s%s error received: id=%04x\n",
> + u8 bus = info->id >> 8;
> + u8 devfn = info->id & 0xff;
> +
> + pci_info(dev, "AER: %s%s error received: %04x:%02x:%02x.%d\n",
> info->multi_error_valid ? "Multiple " : "",
> - aer_error_severity_string[info->severity], info->id);
> + aer_error_severity_string[info->severity],
> + pci_domain_nr(dev->bus), bus, devfn >> 3, devfn & 0x7);
I think PCI_SLOT(devfn), PCI_FUNC(devfn) is a bit more readable.
Powered by blists - more mailing lists