[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAMuHMdX3x_anEXtYyL4BnBoOqRew3MDFSAr6CrRaru0BLpcnZQ@mail.gmail.com>
Date: Tue, 17 Jul 2018 17:26:21 +0200
From: Geert Uytterhoeven <geert@...ux-m68k.org>
To: Daniel Vetter <daniel.vetter@...ll.ch>
Cc: Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
DRI Development <dri-devel@...ts.freedesktop.org>,
Intel Graphics Development <intel-gfx@...ts.freedesktop.org>,
Daniel Vetter <daniel.vetter@...el.com>,
Finn Thain <fthain@...egraphics.com.au>,
linux-m68k <linux-m68k@...ts.linux-m68k.org>
Subject: Re: [PATCH 09/12] nubus: use for_each_if
Hi Daniel,
On Mon, Jul 9, 2018 at 10:44 AM Daniel Vetter <daniel.vetter@...ll.ch> wrote:
> Avoids the inverted check compared to the open-coded version.
>
> Signed-off-by: Daniel Vetter <daniel.vetter@...el.com>
> Cc: Finn Thain <fthain@...egraphics.com.au>
> Cc: linux-m68k@...ts.linux-m68k.org
Thanks for your patch!
> --- a/include/linux/nubus.h
> +++ b/include/linux/nubus.h
> @@ -127,7 +127,7 @@ struct nubus_rsrc *nubus_next_rsrc_or_null(struct nubus_rsrc *from);
> for (f = nubus_first_rsrc_or_null(); f; f = nubus_next_rsrc_or_null(f))
>
> #define for_each_board_func_rsrc(b, f) \
> - for_each_func_rsrc(f) if (f->board != b) {} else
> + for_each_func_rsrc(f) for_each_if (f->board == b)
drivers/net/ethernet/8390/mac8390.c: In function ‘mac8390_device_probe’:
drivers/net/ethernet/8390/mac8390.c:402: error: implicit declaration
of function ‘for_each_if’
drivers/net/ethernet/8390/mac8390.c:402: error: expected ‘;’ before ‘{’ token
Apparently this depends on patch [01/12], which wasn't CCed to
linux-m68k@...ts.linux-m68k.org?
Please don't split CCs if all patches in the a series are not independent.
Thanks!
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Powered by blists - more mailing lists