[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180801182943.22176-1-ndesaulniers@google.com>
Date: Wed, 1 Aug 2018 11:29:43 -0700
From: Nick Desaulniers <ndesaulniers@...gle.com>
To: ysato@...rs.sourceforge.jp, dalias@...c.org
Cc: akpm@...ux-foundation.org, alexander.levin@...izon.com,
linux-sh@...r.kernel.org, linux-kernel@...r.kernel.org,
Nick Desaulniers <ndesaulniers@...gle.com>
Subject: [PATCH] sh: dwarf: prefer _THIS_IP_ to current_text_addr
As part of the effort to reduce the code duplication between _THIS_IP_
and current_text_addr(), let's consolidate callers of
current_text_addr() to use _THIS_IP_.
Signed-off-by: Nick Desaulniers <ndesaulniers@...gle.com>
---
arch/sh/kernel/dwarf.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/sh/kernel/dwarf.c b/arch/sh/kernel/dwarf.c
index 1a2526676a87..bb511e2d9d68 100644
--- a/arch/sh/kernel/dwarf.c
+++ b/arch/sh/kernel/dwarf.c
@@ -599,7 +599,7 @@ struct dwarf_frame *dwarf_unwind_stack(unsigned long pc,
* time this function makes its first function call.
*/
if (!pc || !prev)
- pc = (unsigned long)current_text_addr();
+ pc = _THIS_IP_;
#ifdef CONFIG_FUNCTION_GRAPH_TRACER
/*
--
2.18.0.597.ga71716f1ad-goog
Powered by blists - more mailing lists