lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 12 Sep 2018 09:28:58 -0400
From:   Daniel Jordan <daniel.m.jordan@...cle.com>
To:     Laurent Dufour <ldufour@...ux.vnet.ibm.com>, linux-mm@...ck.org,
        linux-kernel@...r.kernel.org, cgroups@...r.kernel.org
Cc:     aaron.lu@...el.com, ak@...ux.intel.com, akpm@...ux-foundation.org,
        dave.dice@...cle.com, dave.hansen@...ux.intel.com,
        hannes@...xchg.org, levyossi@...oud.com,
        mgorman@...hsingularity.net, mhocko@...nel.org,
        Pavel.Tatashin@...rosoft.com, steven.sistare@...cle.com,
        tim.c.chen@...el.com, vdavydov.dev@...il.com, ying.huang@...el.com,
        daniel.m.jordan@...cle.com
Subject: Re: [RFC PATCH v2 1/8] mm, memcontrol.c: make memcg lru stats
 thread-safe without lru_lock

On 9/11/18 12:32 PM, Laurent Dufour wrote:
> On 11/09/2018 02:42, Daniel Jordan wrote:
>> diff --git a/include/linux/memcontrol.h b/include/linux/memcontrol.h
>> index d99b71bc2c66..6377dc76dc41 100644
>> --- a/include/linux/memcontrol.h
>> +++ b/include/linux/memcontrol.h
>> @@ -99,7 +99,8 @@ struct mem_cgroup_reclaim_iter {
>>   };
>>
>>   struct lruvec_stat {
>> -	long count[NR_VM_NODE_STAT_ITEMS];
>> +	long node[NR_VM_NODE_STAT_ITEMS];
>> +	long lru_zone_size[MAX_NR_ZONES][NR_LRU_LISTS];
> 
> It might be better to use different name for the lru_zone_size field to
> distinguish it from the one in the mem_cgroup_per_node structure.

Yes, not very grep-friendly.  I'll change it to this:

struct lruvec_stat {
	long node_stat_cpu[NR_VM_NODE_STAT_ITEMS];
	long lru_zone_size_cpu[MAX_NR_ZONES][NR_LRU_LISTS];
};

So the fields are named like the corresponding fields in the mem_cgroup_per_node structure, plus _cpu.  And I'm certainly open to other ideas.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ