lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 03 Oct 2018 14:30:46 -0700
From:   Joe Perches <joe@...ches.com>
To:     Michael Straube <straube.linux@...il.com>,
        gregkh@...uxfoundation.org
Cc:     devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/3] staging: rtl8188eu: cleanup array declaration -
 style

On Wed, 2018-10-03 at 22:43 +0200, Michael Straube wrote:
> Cleanup array declaration to clear two 'line over 80 characters'
> checkpatch warnings and improve readability.
[]
> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
[]
> @@ -3836,24 +3836,20 @@ Following are the initialization functions for WiFi MLME
>  *****************************************************************************/
>  
>  static struct mlme_handler mlme_sta_tbl[] = {
> -	{WIFI_ASSOCREQ,		"OnAssocReq",	&OnAssocReq},
> -	{WIFI_ASSOCRSP,		"OnAssocRsp",	&OnAssocRsp},
> -	{WIFI_REASSOCREQ,	"OnReAssocReq",	&OnAssocReq},
> -	{WIFI_REASSOCRSP,	"OnReAssocRsp",	&OnAssocRsp},
> -	{WIFI_PROBEREQ,		"OnProbeReq",	&OnProbeReq},
> -	{WIFI_PROBERSP,		"OnProbeRsp",		&OnProbeRsp},
> -
> -	/*----------------------------------------------------------
> -					below 2 are reserved
> -	-----------------------------------------------------------*/
> -	{0,					"DoReserved",		&DoReserved},
> -	{0,					"DoReserved",		&DoReserved},
> -	{WIFI_BEACON,		"OnBeacon",		&OnBeacon},
> -	{WIFI_ATIM,			"OnATIM",		&OnAtim},
> -	{WIFI_DISASSOC,		"OnDisassoc",		&OnDisassoc},
> -	{WIFI_AUTH,			"OnAuth",		&OnAuthClient},
> -	{WIFI_DEAUTH,		"OnDeAuth",		&OnDeAuth},
> -	{WIFI_ACTION,		"OnAction",		&OnAction},
> +	{WIFI_ASSOCREQ,	  "OnAssocReq",	  &OnAssocReq},
> +	{WIFI_ASSOCRSP,	  "OnAssocRsp",	  &OnAssocRsp},
> +	{WIFI_REASSOCREQ, "OnReAssocReq", &OnAssocReq},
> +	{WIFI_REASSOCRSP, "OnReAssocRsp", &OnAssocRsp},
> +	{WIFI_PROBEREQ,	  "OnProbeReq",	  &OnProbeReq},
> +	{WIFI_PROBERSP,	  "OnProbeRsp",	  &OnProbeRsp},
> +	{0,		  "DoReserved",	  &DoReserved},
> +	{0,		  "DoReserved",	  &DoReserved},
> +	{WIFI_BEACON,	  "OnBeacon",	  &OnBeacon},
> +	{WIFI_ATIM,	  "OnATIM",	  &OnAtim},
> +	{WIFI_DISASSOC,	  "OnDisassoc",	  &OnDisassoc},
> +	{WIFI_AUTH,	  "OnAuth",	  &OnAuthClient},
> +	{WIFI_DEAUTH,	  "OnDeAuth",	  &OnDeAuth},
> +	{WIFI_ACTION,	  "OnAction",	  &OnAction},
>  };

Perhaps const here too, and as well, the struct
declaration could use const char * instead of char *



Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ