[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87089eae-3cf2-8cea-b381-6e721b87ce94@gmail.com>
Date: Thu, 4 Oct 2018 10:20:05 +0200
From: Michael Straube <straube.linux@...il.com>
To: Joe Perches <joe@...ches.com>, gregkh@...uxfoundation.org
Cc: devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/3] staging: rtl8188eu: cleanup array declaration - style
On 10/3/18 11:30 PM, Joe Perches wrote:
> On Wed, 2018-10-03 at 22:43 +0200, Michael Straube wrote:
>> Cleanup array declaration to clear two 'line over 80 characters'
>> checkpatch warnings and improve readability.
> []
>> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
> []
>> @@ -3836,24 +3836,20 @@ Following are the initialization functions for WiFi MLME
>> *****************************************************************************/
>>
>> static struct mlme_handler mlme_sta_tbl[] = {
>> - {WIFI_ASSOCREQ, "OnAssocReq", &OnAssocReq},
>> - {WIFI_ASSOCRSP, "OnAssocRsp", &OnAssocRsp},
>> - {WIFI_REASSOCREQ, "OnReAssocReq", &OnAssocReq},
>> - {WIFI_REASSOCRSP, "OnReAssocRsp", &OnAssocRsp},
>> - {WIFI_PROBEREQ, "OnProbeReq", &OnProbeReq},
>> - {WIFI_PROBERSP, "OnProbeRsp", &OnProbeRsp},
>> -
>> - /*----------------------------------------------------------
>> - below 2 are reserved
>> - -----------------------------------------------------------*/
>> - {0, "DoReserved", &DoReserved},
>> - {0, "DoReserved", &DoReserved},
>> - {WIFI_BEACON, "OnBeacon", &OnBeacon},
>> - {WIFI_ATIM, "OnATIM", &OnAtim},
>> - {WIFI_DISASSOC, "OnDisassoc", &OnDisassoc},
>> - {WIFI_AUTH, "OnAuth", &OnAuthClient},
>> - {WIFI_DEAUTH, "OnDeAuth", &OnDeAuth},
>> - {WIFI_ACTION, "OnAction", &OnAction},
>> + {WIFI_ASSOCREQ, "OnAssocReq", &OnAssocReq},
>> + {WIFI_ASSOCRSP, "OnAssocRsp", &OnAssocRsp},
>> + {WIFI_REASSOCREQ, "OnReAssocReq", &OnAssocReq},
>> + {WIFI_REASSOCRSP, "OnReAssocRsp", &OnAssocRsp},
>> + {WIFI_PROBEREQ, "OnProbeReq", &OnProbeReq},
>> + {WIFI_PROBERSP, "OnProbeRsp", &OnProbeRsp},
>> + {0, "DoReserved", &DoReserved},
>> + {0, "DoReserved", &DoReserved},
>> + {WIFI_BEACON, "OnBeacon", &OnBeacon},
>> + {WIFI_ATIM, "OnATIM", &OnAtim},
>> + {WIFI_DISASSOC, "OnDisassoc", &OnDisassoc},
>> + {WIFI_AUTH, "OnAuth", &OnAuthClient},
>> + {WIFI_DEAUTH, "OnDeAuth", &OnDeAuth},
>> + {WIFI_ACTION, "OnAction", &OnAction},
>> };
>
> Perhaps const here too, and as well, the struct
> declaration could use const char * instead of char *
>
Just to be sure, it should be
static const struct mlme_handler mlme_sta_tbl[] = {
?
Powered by blists - more mailing lists