[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1541607019.196084.210.camel@acm.org>
Date: Wed, 07 Nov 2018 08:10:19 -0800
From: Bart Van Assche <bvanassche@....org>
To: Sagi Grimberg <sagi@...mberg.me>,
Johannes Thumshirn <jthumshirn@...e.de>,
Jens Axboe <axboe@...com>
Cc: Linux Block Layer Mailinglist <linux-block@...r.kernel.org>,
Hannes Reinecke <hare@...e.de>,
Linux Kernel Mailinglist <linux-kernel@...r.kernel.org>,
Jan Kara <jack@...e.cz>
Subject: Re: [PATCH] block: respect virtual boundary mask in bvecs
On Tue, 2018-11-06 at 19:30 -0800, Sagi Grimberg wrote:
> > > How about changing that expression into the following to make it easier
> > > for the compiler to optimize this code?
> > >
> > > (offset | (bprv->bv_offset + bprv->bv_len)) & queue_virt_boundary(q)
> >
> > Uhm I have to admit I'm not really able to parse the above expression.
> > Sure GCC will do it but I think it's less readable (at least for me).
> > Let's see what other's think.
>
> I personally not a huge fan of decoding complicated expressions. But if
> others are fine with it then I am too...
What I proposed is not a new pattern. It is a pattern that is already used
elsewhere in the Linux kernel. A few examples:
>From dmabounce.c:
/* Figure out if we need to bounce from the DMA mask. */
if ((dma_addr | (dma_addr + size - 1)) & ~mask)
return 1;
>From dma-direct.h:
if ((addr | (addr + size - 1)) & ~mask)
return 0;
Bart.
Powered by blists - more mailing lists