[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAFd5g45KNNGPVh4EBm8vKGdVhqajZZA0TU=CFbceJziYufb0Ug@mail.gmail.com>
Date: Tue, 6 Nov 2018 17:28:43 -0800
From: Brendan Higgins <brendanhiggins@...gle.com>
To: shuah@...nel.org
Cc: Greg KH <gregkh@...uxfoundation.org>,
Kees Cook <keescook@...gle.com>, mcgrof@...nel.org,
Joel Stanley <joel@....id.au>, mpe@...erman.id.au,
joe@...ches.com, brakmo@...com, rostedt@...dmis.org,
Tim.Bird@...y.com, khilman@...libre.com,
Julia Lawall <julia.lawall@...6.fr>,
linux-kselftest@...r.kernel.org, kunit-dev@...glegroups.com,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
jdike@...toit.com, richard@....at, linux-um@...ts.infradead.org,
Daniel Vetter <daniel@...ll.ch>,
dri-devel@...ts.freedesktop.org, Rob Herring <robh@...nel.org>,
dan.j.williams@...el.com, linux-nvdimm@...ts.01.org,
kieran.bingham@...asonboard.com
Subject: Re: [RFC v2 01/14] kunit: test: add KUnit test runner core
On Fri, Nov 2, 2018 at 11:44 AM Shuah Khan <shuah@...nel.org> wrote:
>
> On 10/23/2018 05:57 PM, Brendan Higgins wrote:
<snip>
> > + * Example:
> > + *
> > + * .. code-block:: c
> > + *
> > + * void add_test_basic(struct test *test)
> > + * {
> > + * TEST_EXPECT_EQ(test, 1, add(1, 0));
> > + * TEST_EXPECT_EQ(test, 2, add(1, 1));
> > + * TEST_EXPECT_EQ(test, 0, add(-1, 1));
> > + * TEST_EXPECT_EQ(test, INT_MAX, add(0, INT_MAX));
> > + * TEST_EXPECT_EQ(test, -1, add(INT_MAX, INT_MIN));
> > + * }
> > + *
> > + * static struct test_case example_test_cases[] = {
> > + * TEST_CASE(add_test_basic),
> > + * {},
> > + * };
> > + *
> > + */
> > +struct test_case {
> > + void (*run_case)(struct test *test);
> > + const char name[256];
> > +
> > + /* private: internal use only. */
> > + bool success;
> > +};
> > +
>
> Introducing a prefix kunit_* might be a good idea for the API.
> This comment applies to the rest of patches as well.
What about kunit_* instead of test_* and kmock_* instead of mock_*?
Does that seem reasonable?
Powered by blists - more mailing lists