[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20181120132619.GY10650@smile.fi.intel.com>
Date: Tue, 20 Nov 2018 15:26:19 +0200
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Uwe Kleine-König
<u.kleine-koenig@...gutronix.de>
Cc: Phil Edworthy <phil.edworthy@...esas.com>,
Stephen Boyd <sboyd@...nel.org>,
Michael Turquette <mturquette@...libre.com>,
Russell King <linux@...linux.org.uk>,
linux-clk@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-renesas-soc@...r.kernel.org,
Greg Ungerer <gerg@...ux-m68k.org>,
Geert Uytterhoeven <geert@...ux-m68k.org>,
Ralf Baechle <ralf@...ux-mips.org>,
Paul Burton <paul.burton@...s.com>,
James Hogan <jhogan@...nel.org>,
Jiaxun Yang <jiaxun.yang@...goat.com>,
Huacai Chen <chenhc@...ote.com>, Guan Xuetao <gxt@....edu.cn>,
linux-m68k@...ts.linux-m68k.org, linux-mips@...ux-mips.org,
linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH] clk: Add (devm_)clk_get_optional() functions
On Tue, Nov 20, 2018 at 01:56:52PM +0100, Uwe Kleine-König wrote:
> On Tue, Nov 20, 2018 at 12:38:33PM +0200, Andy Shevchenko wrote:
> > On Mon, Nov 19, 2018 at 02:12:59PM +0000, Phil Edworthy wrote:
> > > + if (clk == ERR_PTR(-ENOENT))
> > > + return NULL;
> > > + else
> > > + return clk;
> >
> > return clk == ERR_PTR(-ENOENT) ? NULL : clk;
> >
> > ?
>
> Not sure this adds to the readability of the expression. Personally I
> prefer the explicit if. Maybe even:
>
> clk = clk_get(...);
>
> if (clk == ERR_PTR(-ENOENT))
> clk = NULL;
>
> return clk;
So, it almost repeats the initial variant.
I'm fine with no 'else' in initial code, like
if (...)
return NULL;
return clk;
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists