[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20181120125652.afk2rltmnunfo346@pengutronix.de>
Date: Tue, 20 Nov 2018 13:56:52 +0100
From: Uwe Kleine-König
<u.kleine-koenig@...gutronix.de>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Phil Edworthy <phil.edworthy@...esas.com>,
Stephen Boyd <sboyd@...nel.org>,
Michael Turquette <mturquette@...libre.com>,
Russell King <linux@...linux.org.uk>,
linux-clk@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-renesas-soc@...r.kernel.org,
Greg Ungerer <gerg@...ux-m68k.org>,
Geert Uytterhoeven <geert@...ux-m68k.org>,
Ralf Baechle <ralf@...ux-mips.org>,
Paul Burton <paul.burton@...s.com>,
James Hogan <jhogan@...nel.org>,
Jiaxun Yang <jiaxun.yang@...goat.com>,
Huacai Chen <chenhc@...ote.com>, Guan Xuetao <gxt@....edu.cn>,
linux-m68k@...ts.linux-m68k.org, linux-mips@...ux-mips.org,
linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH] clk: Add (devm_)clk_get_optional() functions
Hello,
On Tue, Nov 20, 2018 at 12:38:33PM +0200, Andy Shevchenko wrote:
> On Mon, Nov 19, 2018 at 02:12:59PM +0000, Phil Edworthy wrote:
> > + if (clk == ERR_PTR(-ENOENT))
> > + return NULL;
> > + else
> > + return clk;
>
> return clk == ERR_PTR(-ENOENT) ? NULL : clk;
>
> ?
Not sure this adds to the readability of the expression. Personally I
prefer the explicit if. Maybe even:
clk = clk_get(...);
if (clk == ERR_PTR(-ENOENT))
clk = NULL;
return clk;
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Powered by blists - more mailing lists