lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 20 Mar 2019 04:22:59 -0700
From:   Matthew Wilcox <willy@...radead.org>
To:     Baoquan He <bhe@...hat.com>
Cc:     Mike Rapoport <rppt@...ux.ibm.com>, linux-kernel@...r.kernel.org,
        akpm@...ux-foundation.org, pasha.tatashin@...cle.com,
        mhocko@...e.com, rppt@...ux.vnet.ibm.com,
        richard.weiyang@...il.com, linux-mm@...ck.org
Subject: Re: [PATCH 2/3] mm/sparse: Optimize sparse_add_one_section()

On Wed, Mar 20, 2019 at 06:13:18PM +0800, Baoquan He wrote:
> +	if (!memmap) {
> +		ret = -ENOMEM;
> +		goto out2;

Documentation/process/coding-style:

Choose label names which say what the goto does or why the goto exists.  An
example of a good name could be ``out_free_buffer:`` if the goto frees ``buffer``.
Avoid using GW-BASIC names like ``err1:`` and ``err2:``, as you would have to
renumber them if you ever add or remove exit paths, and they make correctness
difficult to verify anyway.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ