lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Fri, 22 Mar 2019 15:17:32 +0100
From:   Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To:     Emanuel Bennici <benniciemanuel78@...il.com>
Cc:     linux-kernel@...r.kernel.org,
        Jens Frederich <jfrederich@...il.com>,
        Daniel Drake <dsd@...top.org>,
        Jon Nettleton <jon.nettleton@...il.com>,
        Joe Perches <joe@...ches.com>
Subject: Re: [PATCH] staging: olpc_dcon: Add Tabs to define-Macros

On Fri, Mar 22, 2019 at 10:52:43AM +0100, Emanuel Bennici wrote:
> Improve Code Readability by adding Tabs after #define-Macro
> definition.
> 
> Signed-off-by: Emanuel Bennici <benniciemanuel78@...il.com>
> ---
>  drivers/staging/olpc_dcon/olpc_dcon.h        | 24 ++++++++++----------
>  drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c |  8 +++----
>  2 files changed, 16 insertions(+), 16 deletions(-)
> 
> diff --git a/drivers/staging/olpc_dcon/olpc_dcon.h b/drivers/staging/olpc_dcon/olpc_dcon.h
> index c987aaf894e7..277b19967315 100644
> --- a/drivers/staging/olpc_dcon/olpc_dcon.h
> +++ b/drivers/staging/olpc_dcon/olpc_dcon.h
> @@ -10,18 +10,18 @@
>  #define DCON_REG_ID		 0
>  #define DCON_REG_MODE		 1
>  
> -#define MODE_PASSTHRU	BIT(0)
> -#define MODE_SLEEP	BIT(1)
> -#define MODE_SLEEP_AUTO	BIT(2)
> -#define MODE_BL_ENABLE	BIT(3)
> -#define MODE_BLANK	BIT(4)
> -#define MODE_CSWIZZLE	BIT(5)
> -#define MODE_COL_AA	BIT(6)
> -#define MODE_MONO_LUMA	BIT(7)
> -#define MODE_SCAN_INT	BIT(8)
> -#define MODE_CLOCKDIV	BIT(9)
> -#define MODE_DEBUG	BIT(14)
> -#define MODE_SELFTEST	BIT(15)
> +#define MODE_PASSTHRU		BIT(0)
> +#define MODE_SLEEP		BIT(1)
> +#define MODE_SLEEP_AUTO		BIT(2)
> +#define MODE_BL_ENABLE		BIT(3)
> +#define MODE_BLANK		BIT(4)
> +#define MODE_CSWIZZLE		BIT(5)
> +#define MODE_COL_AA		BIT(6)
> +#define MODE_MONO_LUMA		BIT(7)
> +#define MODE_SCAN_INT		BIT(8)
> +#define MODE_CLOCKDIV		BIT(9)
> +#define MODE_DEBUG		BIT(14)
> +#define MODE_SELFTEST		BIT(15)

These really did not have to be changed, did they?

>  
>  #define DCON_REG_HRES		0x2
>  #define DCON_REG_HTOTAL		0x3
> diff --git a/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c b/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
> index 838daa2be3ef..7972b591d1b8 100644
> --- a/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
> +++ b/drivers/staging/olpc_dcon/olpc_dcon_xo_1_5.c
> @@ -31,10 +31,10 @@
>   *	DCONSMBCLK connects to VX855 graphics CRTSPCLK
>   */
>  
> -#define VX855_GENL_PURPOSE_OUTPUT 0x44c /* PMIO_Rx4c-4f */
> -#define VX855_GPI_STATUS_CHG 0x450  /* PMIO_Rx50 */
> -#define VX855_GPI_SCI_SMI 0x452  /* PMIO_Rx52 */
> -#define BIT_GPIO12 0x40
> +#define VX855_GENL_PURPOSE_OUTPUT	0x44c /* PMIO_Rx4c-4f */
> +#define VX855_GPI_STATUS_CHG		0x450  /* PMIO_Rx50 */
> +#define VX855_GPI_SCI_SMI		0x452  /* PMIO_Rx52 */
> +#define BIT_GPIO12			0x40

Also use a tab before the comment on these lines.

thanks,

greg k-h

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ