[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190326131626.GZ9224@smile.fi.intel.com>
Date: Tue, 26 Mar 2019 15:16:26 +0200
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Sakari Ailus <sakari.ailus@...ux.intel.com>
Cc: Petr Mladek <pmladek@...e.com>, linux-kernel@...r.kernel.org,
rafael@...nel.org, linux-acpi@...r.kernel.org,
devicetree@...r.kernel.org, Rob Herring <robh@...nel.org>
Subject: Re: [PATCH v2 3/6] device property: Add a function to obtain a
node's prefix
On Tue, Mar 26, 2019 at 02:41:03PM +0200, Sakari Ailus wrote:
> The prefix is used for printing purpose before a node, and it also works
> as a separator between two nodes.
>
One nit below.
> +static const char *
> +acpi_fwnode_get_name_prefix(const struct fwnode_handle *fwnode)
> +{
> + struct fwnode_handle *parent;
> +
> + parent = fwnode_get_parent(fwnode);
> + /* Root node. */
I guess a comment could be easier to read if it goes before parent assignment
line.
> + if (!parent)
> + return "";
> +
> + parent = fwnode_get_next_parent(parent);
> + /* Second node from the root; no prefix here either. */
Ditto.
> + if (!parent)
> + return "";
> +
> + fwnode_handle_put(parent);
> +
> + /* ACPI device or data node. */
> + return ".";
> +}
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists