lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 27 Mar 2019 16:19:41 +0200
From:   Tzvetomir Stoyanov <tstoyanov@...are.com>
To:     rostedt@...dmis.org
Cc:     linux-trace-devel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: [PATCH v2 0/5] Cleanup traceevent API and make it more consistent

[
 v2 changes:
  - Excluded patches:
     "tools/lib/traceevent: Remove tep filter trivial APIs"
     "tools/lib/traceevent: remove call to exit() from tep_filter_add_filter_str()"
    from the series, as they are already merged.
  - Dropped patch "tools/lib/traceevent: Add counter to track parsing failures",
    this functionality will not be part of the traceevent library. Applications
    should track parsing failures themselves.
  - Few minor changes, to address Steven Rostedt comments 
]

This patch series does a cleanup of traceevent implementation and APIs:
 - All "pevent" function parameters and local variables are renamed to "tep". 
   This makes the implementation consistent with the chosen naming convention, 
   tep (trace event parser), and avoids any confusion with the old "pevent" name. 
 - Renamed a bunch of tracevent APIs, to make names consistent and descriptive.
 - Unified all tep_is_... APIs to return bool value, instead of int.

Changes depend on "Few patches, related to libtracevent APIs" patchset and 
should be applied on top of it.

Tzvetomir Stoyanov (5):
  tools/perf,tools/lib/traceevent: Make traceevent APIs more consistent
  tools/lib/traceevent: Rename input arguments of libtraceevent APIs
    from pevent to tep
  tools/perf,tools/lib/traceevent: Rename "pevent" member of struct
    tep_event to "tep"
  tools/perf,tools/lib/traceevent: Rename "pevent" member of struct
    tep_event_filter to "tep"
  tools/lib/traceevent: Rename input arguments and local variables of
    libtraceevent from pevent to tep

 tools/lib/traceevent/event-parse-api.c        | 152 ++--
 tools/lib/traceevent/event-parse-local.h      |   6 +-
 tools/lib/traceevent/event-parse.c            | 811 +++++++++---------
 tools/lib/traceevent/event-parse.h            | 130 +--
 tools/lib/traceevent/event-plugin.c           |  32 +-
 tools/lib/traceevent/parse-filter.c           |  46 +-
 tools/lib/traceevent/plugin_cfg80211.c        |   8 +-
 tools/lib/traceevent/plugin_function.c        |  14 +-
 tools/lib/traceevent/plugin_hrtimer.c         |  12 +-
 tools/lib/traceevent/plugin_jbd2.c            |  12 +-
 tools/lib/traceevent/plugin_kmem.c            |  32 +-
 tools/lib/traceevent/plugin_kvm.c             |  48 +-
 tools/lib/traceevent/plugin_mac80211.c        |   8 +-
 tools/lib/traceevent/plugin_sched_switch.c    |  18 +-
 tools/lib/traceevent/plugin_scsi.c            |   8 +-
 tools/lib/traceevent/plugin_xen.c             |   8 +-
 tools/perf/builtin-kmem.c                     |   2 +-
 tools/perf/util/data-convert-bt.c             |   4 +-
 tools/perf/util/python.c                      |   2 +-
 .../util/scripting-engines/trace-event-perl.c |   2 +-
 .../scripting-engines/trace-event-python.c    |   2 +-
 tools/perf/util/trace-event-parse.c           |   2 +-
 tools/perf/util/trace-event-read.c            |   2 +-
 tools/perf/util/trace-event.c                 |   4 +-
 24 files changed, 682 insertions(+), 683 deletions(-)

-- 
2.20.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ