[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190409100436.GA28683@infradead.org>
Date: Tue, 9 Apr 2019 03:04:36 -0700
From: Christoph Hellwig <hch@...radead.org>
To: Andriy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Jacob Pan <jacob.jun.pan@...ux.intel.com>,
iommu@...ts.linux-foundation.org,
LKML <linux-kernel@...r.kernel.org>,
Joerg Roedel <joro@...tes.org>,
David Woodhouse <dwmw2@...radead.org>,
Alex Williamson <alex.williamson@...hat.com>,
Jean-Philippe Brucker <jean-philippe.brucker@....com>,
Yi Liu <yi.l.liu@...el.com>,
"Tian, Kevin" <kevin.tian@...el.com>,
Raj Ashok <ashok.raj@...el.com>,
Christoph Hellwig <hch@...radead.org>,
Lu Baolu <baolu.lu@...ux.intel.com>,
"Paul E. McKenney" <paulmck@...ux.ibm.com>
Subject: Re: [PATCH 01/18] drivers core: Add I/O ASID allocator
On Tue, Apr 09, 2019 at 01:00:49PM +0300, Andriy Shevchenko wrote:
> I think it makes sense to add a helper macro to rcupdate.h
> (and we have several cases in kernel that can utilize it)
>
> #define kfree_non_null_rcu(ptr, rcu_head) \
> do { \
> if (ptr) \
> kfree_rcu(ptr, rcu_head); \
> } while (0)
>
> as a more common pattern for resource deallocators.
I think that should move straight into kfree_rcu. In general
we expect *free* to deal with NULL pointers transparently, so we
should do so here as well.
Powered by blists - more mailing lists