lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 11 Apr 2019 23:30:23 -0700
From:   "Darrick J. Wong" <darrick.wong@...cle.com>
To:     "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc:     linux-xfs@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] xfs: use struct_size() helper

On Thu, Apr 11, 2019 at 08:57:14PM -0500, Gustavo A. R. Silva wrote:
> 
> 
> On 4/11/19 7:19 PM, Darrick J. Wong wrote:
> > [fixing linux-xfs cc]
> > 
> 
> Thanks for this.
> 
> > On Thu, Apr 11, 2019 at 06:37:58PM -0500, Gustavo A. R. Silva wrote:
> >> Make use of the struct_size() helper instead of an open-coded  version
> >> in order to avoid any potential type mistakes, in particular in the
> >> context in which this code is being used.
> >>
> >> So, replace code of the following form:
> >>
> >> sizeof(*alist) + context->count * sizeof(alist->al_offset[0]
> >>
> >> with:
> >>
> >> struct_size(alist, al_offset, context->count)
> >>
> >> and remove unnecessary variable arraytop.
> >>
> >> This code was detected with the help of Coccinelle.
> >>
> >> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> > 
> > Has this been run through xfstests?
> > 
> 
> No.  Is this a requirement?

Yes, since this is a change to core functionality (and my eyes aren't so
good at digging through preprocessor macros...)

--D

> Thanks
> --
> Gustavo
> 
> > --D
> > 
> >>  fs/xfs/xfs_attr_list.c | 5 +----
> >>  1 file changed, 1 insertion(+), 4 deletions(-)
> >>
> >> diff --git a/fs/xfs/xfs_attr_list.c b/fs/xfs/xfs_attr_list.c
> >> index 3d213a7394c5..05e03348553e 100644
> >> --- a/fs/xfs/xfs_attr_list.c
> >> +++ b/fs/xfs/xfs_attr_list.c
> >> @@ -553,7 +553,6 @@ xfs_attr_put_listent(
> >>  {
> >>  	struct attrlist *alist = (struct attrlist *)context->alist;
> >>  	attrlist_ent_t *aep;
> >> -	int arraytop;
> >>  
> >>  	ASSERT(!context->seen_enough);
> >>  	ASSERT(!(context->flags & ATTR_KERNOVAL));
> >> @@ -572,10 +571,8 @@ xfs_attr_put_listent(
> >>  	    ((flags & XFS_ATTR_ROOT) == 0))
> >>  		return;
> >>  
> >> -	arraytop = sizeof(*alist) +
> >> -			context->count * sizeof(alist->al_offset[0]);
> >>  	context->firstu -= ATTR_ENTSIZE(namelen);
> >> -	if (context->firstu < arraytop) {
> >> +	if (context->firstu < struct_size(alist, al_offset, context->count)) {
> >>  		trace_xfs_attr_list_full(context);
> >>  		alist->al_more = 1;
> >>  		context->seen_enough = 1;
> >> -- 
> >> 2.21.0
> >>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ