[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190624075718.GE5471@krava>
Date: Mon, 24 Jun 2019 09:57:18 +0200
From: Jiri Olsa <jolsa@...hat.com>
To: Jin Yao <yao.jin@...ux.intel.com>
Cc: acme@...nel.org, jolsa@...nel.org, peterz@...radead.org,
mingo@...hat.com, alexander.shishkin@...ux.intel.com,
Linux-kernel@...r.kernel.org, ak@...ux.intel.com,
kan.liang@...el.com, yao.jin@...el.com
Subject: Re: [PATCH v4 4/7] perf diff: Use hists to manage basic blocks per
symbol
On Thu, Jun 20, 2019 at 10:36:39PM +0800, Jin Yao wrote:
SNIP
> +
> +static void *block_entry_zalloc(size_t size)
> +{
> + return zalloc(size + sizeof(struct hist_entry));
> +}
> +
> +static void block_entry_free(void *he)
> +{
> + struct block_info *bi = ((struct hist_entry *)he)->block_info;
> +
> + block_info__put(bi);
> + free(he);
> +}
> +
> +struct hist_entry_ops block_entry_ops = {
> + .new = block_entry_zalloc,
> + .free = block_entry_free,
> +};
hum, so there's already block_hist_ops moving that stuff into 'struct block_hist',
which is great, but why don't we have 'struct block_entry' in here? that would
keep the 'struct block_info'
thanks,
jirka
Powered by blists - more mailing lists