lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 26 Jun 2019 23:20:14 +0200
From:   Ingo Molnar <mingo@...nel.org>
To:     Thomas Gleixner <tglx@...utronix.de>
Cc:     LKML <linux-kernel@...r.kernel.org>, x86@...nel.org,
        Peter Zijlstra <peterz@...radead.org>,
        Ricardo Neri <ricardo.neri-calderon@...ux.intel.com>,
        Ashok Raj <ashok.raj@...el.com>,
        Andi Kleen <andi.kleen@...el.com>,
        Suravee Suthikulpanit <Suravee.Suthikulpanit@....com>,
        Stephane Eranian <eranian@...gle.com>,
        Ravi Shankar <ravi.v.shankar@...el.com>
Subject: Re: [patch 24/29] x86/hpet: Use cached info instead of extra flags


* Thomas Gleixner <tglx@...utronix.de> wrote:

> Now that HPET clockevent support is integrated into the channel data, reuse
> the cached boot configuration instead of copying the same information into
> a flags field.
> 
> This also allows to consolidate the reservation code into one place, which
> can now solely depend on the mode information.
> 
> Signed-off-by: Thomas Gleixner <tglx@...utronix.de>
> ---
>  arch/x86/kernel/hpet.c |   76 ++++++++++++++-----------------------------------
>  1 file changed, 23 insertions(+), 53 deletions(-)
> 
> --- a/arch/x86/kernel/hpet.c
> +++ b/arch/x86/kernel/hpet.c
> @@ -25,8 +25,8 @@ struct hpet_channel {
>  	unsigned int			num;
>  	unsigned int			cpu;
>  	unsigned int			irq;
> +	unsigned int			inuse;
>  	enum hpet_mode			mode;
> -	unsigned int			flags;
>  	unsigned int			boot_cfg;
>  	char				name[10];

Let's fight entropy name by name and s/inuse/in_use ?

Because in_use is closer to harmony:

 dagon:~/tip> git grep -w in_use | wc -l
 518
 dagon:~/tip> git grep -w inuse | wc -l
 318

and also easier to read.

Reviewed-by: Ingo Molnar <mingo@...nel.org>

Thanks,

	Ingo

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ